WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

PHP Version Finder

— Add-On auf WorldWideScripts.net

@de1wwsAbonniere den Feed um auf dem neuesten Stand zu bleiben!

Neu! Folge uns, wie Du es möchtest!


PHP Version Finder - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Folge mir auf Twitter Folgen Sie mir auf G + Follow Me On CodeCanyon Echtzeit Vorführung

Demo - Non - Datenbank (Krüppel)
Demo - Datenbank (Krüppel)
Die Demos sind gelähmt! Wir haben die wahre Version der einzelnen Funktionen und Erweiterung verschlüsselt ist.

PHP Version Finder - Aktualisiert v 1.0.3c 2010.12.09

Finden Sie, welche Version von PHP Skript erfordert. Auf die Frage, welche Version von PHP benötigt wird unsere Skripte auszuführen haben wir nicht eine endgültige Antwort. Wir haben dieses Skript die PHP-Version zu bestimmen, und dann haben wir es auf eine andere Ebene von veralteten Funktionen sucht aus. Aber wir hörten nicht nur dazu. Wir enthalten PHP-Erweiterungen und Sprachkonstrukte. Wir nannten es fast gut an das, aber dann haben wir uns gefragt... wie oft wir diese Funktionen verwendet. Der übermäßige Gebrauch von der gleichen Funktion kann auf die Leistung einer Verschlechterung. Überwachen, wie oft eine Funktion verwendet wird, kann helfen, festzustellen, ob ein "User Created Funktion" erstellt werden können Code zu reduzieren und die Leistung zu erhöhen.

Entdeckung

PHP Version Finder verfolgt: 3044 PHP-Funktionen, 2260 PHP-Erweiterungen, 23 Sprachkonstrukten, 19 Alternative Vorschläge, 7 Tipps / Tricks / Hinweise. (Plus 69 Experimentell, 20 Veraltete, 47 "svn" Funktionen)
Der Code muss nicht vollständig sein, noch funktioniert. Es muss nicht einmal Sinn machen. Solange es zwischen <? Php und?> Es wird ausgewertet. Crippled Demo - Die Demo verkrüppelt wurde, um Menschen daran zu hindern, es zu benutzen, anstatt den Kauf es.

Stoppen Sie Erraten!

Die Wahrheit zu sagen - die meisten Entwickler "Ball-Park", welche Version von PHP benötigt wird durch ein paar "Schlüssel" Funktionen unter Hinweis auf sie verwendet. Mit der PHP-Version Finder können Sie sicher wissen, was PHP-Version tatsächlich benötigt wird!
Raten Sie nicht! - Run PHP Version Finder auf Ihrem Skript zu wissen sicher, was verions von PHP benötigt, um Ihre Skript zu bedienen!

Veraltete Erkennung

PHP Version Finder können Sie wissen, ob irgendwelche Funktionen, die Sie als veraltet verwendet werden.
Veraltete Erkennung - Prüfen Sie Ihre Skripte für veralteten Funktionen

Zwei Versionen

Die PHP-Version Finder benötigt keine Datenbank. für diejenigen von euch jedoch, die eher eine Datenbank verwenden würde, tut das Skript eine Datenbank-Version enthalten.
Optionhal Datenbank - PHP Version Finder keine Datenbank benötigen, jedoch eine alternative Version ist für diejenigen geliefert, die eine Datenbank verwenden wollen.
Warum zwei Versionen?
Es kommt alles auf die Zahlen. Wenn es viele PHP-Funktionen sind, ist die NON-Datenbank-Version schneller. Wenn es nur wenige Funktionen sind, ist die Datenbankversion schneller. Wie viel schneller? Nun, es ist gemessen in Mikrosekunden. Also nicht wirklich spürbar. Nachdem wir die Datenbank-Version gemacht haben wir beschlossen, es nicht der Mühe wert war, als seine Leistung anders nicht erkennbar war. Wir beschlossen, es zu schließen, weil sie bereits gebaut wurde - ein Freebie, wenn Sie mögen.

Installation

Die Installation ist einfach. Laden Sie das Verzeichnis, bearbeiten zwei Einstellungen und du bist fertig.
Installion - Hochladen von 1 Verzeichnis auf den Server, bearbeiten Sie eine Konfigurationsdatei und Ihr bereit zu gehen!

Eingänge

Sie können eine Datei von Ihrem Computer hochladen, scannen eine Datei oder ein ganzes Verzeichnis auf dem Server oder Einfügen von Code in einer Box für die Verarbeitung.
Mehrere Eingänge - Sie können eine Datei laden, ein Verzeichnis scannen oder einen Codeblock überprüfen.

Alternative Vorschläge

Wenn der PHP-Version Finder-Funktionen findet, die veraltet sind, wird es Ihnen alternative Vorschläge geben, die die veraltete Funktion ersetzen könnte.
Alternative Vorschläge - Sie können Ihr Skript machen Beispielsweise:
wenn Sie file_put_contents verwenden (was erfordert PHP 5), PHP Version Finder wird Sie wissen lassen, dass Sie fwrite stattdessen verwenden könnte, welche die erforderliche Version bis auf PHP 4. Nicht nur, dass senken könnte, aber es ist ein Hinweis auf file_put_contents angebracht, die Ihnen zeigt, der Code zu verwenden file_put_contents rückwärts kompatibel zu machen.

Erwerben Sie PHP Version Finder JETZT!

Make Life Easy! Finden veralteten Funktionen, erhalten rückwärtskompatibel Vorschläge und wissen, welche Version von PHP Ihre Skripte benötigt wird ausgeführt
Bestellen Sie jetzt - machen das Leben einfacher, veralteten Funktionen finden, erhalten rückwärtskompatibel Vorschläge und wissen, welche Version von PHP benötigt, um Ihre Skripte auszuführen.

Aktuelle Features (v 1.0.0) - 2010.12.01

  • Optional Datenbank
  • Veraltete Erkennung
  • Datei-Upload-Verarbeitung
  • Directory-Verarbeitung
  • Geklebte Codeverarbeitung
  • Auto-Vervollständigen
  • Syntax Highlighter
  • 3044 PHP-Funktionen
  • 2260 PHP-Erweiterungen
  • 23 Sprachkonstrukten
  • 19 Alternative Vorschläge
  • 7 Tipps / Tricks / Hinweise
  • Plus-69 Experimentelle Funktionen
  • Plus 20 Veraltete Funktionen
  • Plus-47 "svn" / unbekannte Funktionen

Update v 1.0.1 2010.12.03

  • Feste Hinweis Warnungen
  • Fixed "nicht definierte Variablen" Fehler
  • Feste Spelling Errors
  • Aktualisiert Hilfedatei, um den Änderungen
  • Hinzugefügt Lizenzierung Erklärung
  • Aufgeräumt den "Report File"

Update v 1.0.2 2010.12.04

  • Feste Hinweis Warnungen
  • Fixed "nicht definierte Variablen" Fehler
  • Aktualisiert Hilfedatei, um den Änderungen

Update v 1.0.3c 2010.12.09

  • Aufgeräumt Code
  • Neu geschrieben, wie Statistiken ausgezählt werden.
  • Schrieb die "Report-Datei"

Herunterladen
Weitere Komponenten in dieser KategorieAlle Komponenten dieses Autors
KommentareHäufige Fragen und Antworten

Eigenschaften

Erstellt:
3. Dezember 10

Letztes Update:
10. Dezember 10

Hohe Auflösung:
Nein

kompatible Browser:
IE7, IE8, Safari, Opera

Dateien inklusive:
JavaScript JS, HTML, CSS, PHP, SQL

Softwareversion:
PHP 4.x, PHP 5.x, PHP 5,0-5,2, PHP 5.3, MySQL 5.x

Stichworte

E-Commerce, E-Commerce, Alle Elemente, veraltet Warnung, pHP-Version, Syntax-Hervorhebung